Close

Problém s připojením arduino klon CH340G

Úvodní stránka Fórum Software Drivery Problém s připojením arduino klon CH340G

Zvolené téma obsahuje celkem 5 odpovědí. Do diskuze (3 hlasy) se naposledy zapojil uživatel Profilový obrázek jarous5 a poslední změna proběhla před 1 rok, 2 měsíců.

Prohlížíte 6 příspěvků - 1 z 6 (z 6 celkově)
  • Autor
    Příspěvky
  • #7203
    Profilový obrázek
    petrcaltik
    Účastník

    Dobrý den,
    mám problém s připojením klonu arduino Uno s čipem CH340G. Když nainstaluji ovladač ch341 nezobrazí se žádný port COM… Zkoušel jsem port přidat ručně to se mi podařilo ale zobrazuje se s vykřičníkem a připojené arduino stejně nefunguje… Ještě jsem někde vyčetl a stáhl USB Deview, kde se připojené arduino také nezobrazuje. Zkoušel jsem dva různé USB kabely… Mělo by tam být vidět i v případě, že není ovladač arduina nainstalovaný? Opravdu si už nevím rady, budu rád za jakékoliv nápady..

    #7211
    Profilový obrázek
    posjirka
    Účastník

    zkus to na jiném PC a pak zkus jiný kus arduina. CH340 mohla odejít do věčných digitálních lovišť. Kdyby odešel tak Arduino nemusíš vyhazovat. Můžeš jej naprogramovat přes ICSP port a použit v nějáké aplikaci.
    Napadá mě ještě chybný konektor (zapatlané piny na konektoru), vadný krystal pro Ch340g a pod.
    Když to Arduino zapojíš do USB portu tak předpokládám, že LED POWER svítí a LED „L“ na 13 pinu bliká (defaultní program blik). Pokud jo tak Arduino funguje a je to chyba jen komunikace. My máme 3 klony s tímto čipem a všechny fungují ….

    #7212
    Profilový obrázek
    petrcaltik
    Účastník

    Problém vyřešen… :-) Při zoufalém zkoušení jsem začal prohlížet všechny pájené spoje a zjistil jsem že dva kontakty USB konektoru na arduinu jsou spájené, po proškrábnutí nožem vše funguje! :-) posjirka-díky za reakci! :-)

    #7214
    Profilový obrázek
    petrcaltik
    Účastník

    Fotka se mi nedaří nahrát…

    #7216
    Profilový obrázek
    posjirka
    Účastník

    zřejmě čínská pomsta zahnívajícímu západnímu kapitalusmu :)
    Ne vážně, to se občas stane a je super že jsi na to přišel sám.
    Chybami se člověk učí. Hlavně že to funguje.

    #13359
    Profilový obrázek
    jarous5
    Účastník

    Ahoj mám takový problém.. vždycky jsem chtěl už jako malý si hrát s programovací stavebnici. Jenže až teď ve starším věku se mi to mohlo splnit. bohužel jsem si koupil po internetu arduino klona. chtěl jsem ho zprovoznit , ale marně. nechtěli se mi nainstalovat aktualizace a když jsem zkoušel stáhnout jaký si instalační driver, taktéž marně. vůbec se mi nezobrazuje nějaký usb 2.0 a v serial portálu ani příšlusný port pro arduino.. už si fakt nevím rady jak to zprovoznit. tolik jsem se těšil až si něco poskládám a vyzkouším.. akorát jsem jenom zklamaný. po připojení arduina k pc svítí stavová led zelená a druhá led L jenom oranžové bliká po asi cca 2sekund. mám typ chipu Atmel mega 16u2 1722 PH A96UB tak jestli by mi někdo poradil už jsem fakt zoufalý… děkuji moc

Prohlížíte 6 příspěvků - 1 z 6 (z 6 celkově)

Pro reakci na tento článek se musíte přihlásit.